Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

VZ Orientation Interruption
Incident Report for MSU Denver ITS
Resolved
The issue has been resolved, thank you for your patience.
Posted 10 months ago. Dec 06, 2018 - 10:00 MST
Investigating
At this time, MSU Denver is experiencing aSERVICE DEGRADATION] on VZ Orientation]. Technicians are aware of the issue and are working to resolve the issue as quickly as possible.
Posted 10 months ago. Dec 05, 2018 - 11:46 MST