Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Helpdesk Phone System Service Interruption
Incident Report for MSU Denver ITS
Resolved
We have isolated the issue and no longer experiencing any degraded services for the Helpdesk Phone Systems. Thank you for your patience and understanding while we resolved this incident.
Posted Apr 04, 2018 - 10:22 MDT
Investigating
The Helpdesk Phone System is experiencing service degradation again. You may experience a longer delay for your phone call to be answered or your call may get disconnected. Please continue to stay on the line or retry if you do get disconnected.
Posted Mar 05, 2018 - 13:09 MST
Monitoring
The Helpdesk Phone System is operating as normal. We will continue to monitor this incident into next week.
Posted Mar 02, 2018 - 13:40 MST
Investigating
The Helpdesk Phone System is continuing to experience service degradation. You may experience a longer delay for your phone call to be answered or your call may get disconnected. Please continue to stay on the line or retry if you do get disconnected. Our escalated vendor support is continuing to investigate our issue. We anticipate a status update on this issue in 24 hours.

Thank you for your patience and apologies for any inconvenience.
Posted Mar 01, 2018 - 12:14 MST
Update
The issue is still on-going. We are continuing to work directly with our vendor and should have another update by 12pm, today.
Posted Mar 01, 2018 - 09:51 MST
Identified
The issue is still on-going. We are continuing to work with our consultant whom have gather logs and opened a case directly with ShoreTel for escalated support. Will provide an update by tomorrow 10 am if not sooner.
Posted Feb 28, 2018 - 16:24 MST
Monitoring
At this time, MSU Denver is experiencing an unplanned service degradation on the ITS Helpdesk phone system. Technicians are aware of the issue and are working to resolve the issue as quickly as possible. We anticipate a status update on this issue in 180 minutes.
Posted Feb 28, 2018 - 14:12 MST