Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

MSUDenver.edu Homepage Not Loading Without WWW Prefix
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 09:08 MST
Investigating
Some users are reporting that the University website is not loading correctly without including a "www." in the URL. Technicians have been notified and are investigating the issue, in the meantime all users can enter 'www.msudenver.edu' to access the site.
Posted Jan 07, 2021 - 08:30 MST
This incident affected: Campus Web Hosting.