Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

MFA Two Factor Authentication
Incident Report for MSU Denver ITS
Resolved
Issue with MFA multi-factor authentication has been resolved.
Posted Jan 11, 2021 - 10:08 MST
Update
We are continuing to investigate this issue.
Posted Jan 11, 2021 - 10:06 MST
Investigating
Users are currently experiencing an issue authenticating with their multi-factor authentication when using the phone call method to verify sign-in. We are reaching out to Microsoft for updates.

If you have a smart phone, you can utilize the Authenticator app to authenticate successfully. https://www.msudenver.edu/accounttypes/mfa/ . Our technicians will be able to assist you with this transition to the app if you call us at 303-352-7548 but please note we are experiencing high call volume at this time to assist everyone affected.
Posted Jan 11, 2021 - 09:59 MST
This incident affected: Authentication & Single Sign On.