Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Network issues in JSSB
Incident Report for MSU Denver ITS
Resolved
The JSSB MSU Network is up and available. Please contact the MSU Help desk for any network assistance.
Posted Jul 17, 2024 - 12:16 MDT
Monitoring
During a planned AHEC power outage the MSU network in JSSB was unexpectedly affected. AHEC has restored power. The JSSB MSU Network is up and available. Please contact the MSU Help desk for any network assistance.
Posted Jul 17, 2024 - 08:45 MDT
This incident affected: Campus Network.