Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Team Issues - lag and delay in messages
Incident Report for MSU Denver ITS
Resolved
Microsoft resolved the team issue
Posted Jan 26, 2024 - 20:21 MST
Update
Microsoft is continuing to work on this issue affecting Teams performance globally.

Latest updates from Microsoft can be found at https://portal.office.com/servicestatus.
Posted Jan 26, 2024 - 19:17 MST
Update
Microsoft is continuing to work on this issue affecting Teams performance globally.

Latest updates from Microsoft can be found at https://portal.office.com/servicestatus.

Microsoft next schedule update is 7:30pm MST
Posted Jan 26, 2024 - 18:09 MST
Update
Microsoft is continuing to work on this issue affecting Teams performance globally.

Latest updates from Microsoft can be found at https://portal.office.com/servicestatus.
Posted Jan 26, 2024 - 16:29 MST
Update
Microsoft is continuing to work on this issue. There is no update from Microsoft.
Posted Jan 26, 2024 - 15:31 MST
Identified
Multiple users are experiencing issues with Teams. Lag in message delivery, unable to make posts on channels, delayed delivery of notifications, etc. This is a known service degradation on the side of the service provider, Microsoft.

The most up-to-date status information can be found on this Microsoft site: https://portal.office.com/servicestatus

MSU Denver IT Services will continue to update our status page here as we receive updates from Microsoft.
Posted Jan 26, 2024 - 14:05 MST
Investigating
We are currently investigating this issues

Major ticket 24685101
Posted Jan 26, 2024 - 11:21 MST
This incident affected: Office 365/Email.