Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Part of network on 2nd floor of Central Building is down.
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Aug 21, 2024 - 16:56 MDT
Investigating
We are currently investigating this issue.
Posted Aug 21, 2024 - 16:36 MDT
This incident affected: Campus Network and Campus Wireless Network.