Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Intermittent network slowness on campus.
Incident Report for MSU Denver ITS
Resolved
No further network degradation has been reported or recorded since yesterday evening. Though we continue to monitor for a recurrence, it appears that the issue has been resolved. A root cause analysis will be conducted as part of the Problem Ticket created from this Major Incident.
Posted Jan 09, 2025 - 13:30 MST
Monitoring
Network congestion has subsided. Short of a firm root cause, the team will continue monitoring into the workday tomorrow.
Posted Jan 08, 2025 - 20:41 MST
Update
Network speeds are normal for now, but we are still investigating the root cause of traffic issues.
Posted Jan 08, 2025 - 16:39 MST
Investigating
Intermittent network slowness has been reported on both wired and wireless connections. ITS is actively investigating the issue.
Posted Jan 08, 2025 - 13:31 MST
This incident affected: Campus Network.