Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Outbound Campus phone calls cutting out after 5 minutes (Skype for Business)
Incident Report for MSU Denver ITS
Resolved
A fix has been implemented and normal service is restored to the campus phone/Skype for Business system.

If you still experience any issues with calls cutting out after a few minutes or not going through from your desk phone or Skype for Business desktop app, please call our IT Service Desk at 303-25-7548 or submit a ticket here:

https://msudenver.teamdynamix.com/TDClient/2313/Portal/Requests/ServiceDet?ID=46016
Posted Mar 22, 2022 - 20:31 MDT
Identified
ITS has identified the issue with outbound calls from campus phones/Skype for Business getting cut off after 5 minutes. We will be implementing and testing a fix after 5pm so as to not interrupt all phone calls during the work day.

We will update this service status after 5pm today.
Posted Mar 22, 2022 - 15:08 MDT
Investigating
ITS has received reports of phone calls to and from campus desk phones and Skype for Business cutting out after 5 minutes and dropping the call.

We are investigating the scope of impact and root cause.
Posted Mar 22, 2022 - 13:44 MDT
This incident affected: Telecommunications and Skype for Business.