Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Microsoft Safelinks
Incident Report for MSU Denver ITS
Resolved
This issue has been resolved by Microsoft.
Posted 6 months ago. Jan 30, 2019 - 11:10 MST
Identified
The Microsoft Safelinks system which scans links in emails for potential dangerous destinations is experiencing interruptions. This may cause users to receive errors when attempting to access links in email. Microsoft is working on the issue.
Posted 6 months ago. Jan 29, 2019 - 08:28 MST
This incident affected: Office 365/Email.