Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner Service Outage for Admin pages, Self Service
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 13:30 MDT
Investigating
We have received multiple reports of Banner service outage for Banner admin pages and self-service banner. Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Oct 20, 2021 - 13:22 MDT
This incident affected: Self Service Banner 8 (Faculty Self Service, Employee Self-Service, Finance Self-Service) and Internet Native Banner (Banner Admin Pages) - Production.