Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner Self Service Interruption
Incident Report for MSU Denver ITS
Resolved
Incident is resolved.
Posted 5 months ago. May 19, 2019 - 17:12 MDT
Update
We are continuing to troubleshoot Banner Self Service and will provide another update within the next 60 minutes.
Posted 5 months ago. May 19, 2019 - 16:35 MDT
Identified
We are continuing to investigate the issue, but believe that we have identified it. Another update will follow within the next 60 minutes.
Posted 5 months ago. May 19, 2019 - 15:43 MDT
Update
We are continuing to investigate this issue and will provide another update in 60 minutes.
Posted 5 months ago. May 19, 2019 - 14:38 MDT
Investigating
At this time, MSU Denver is experiencing an unplanned outage on Banner Self Service. Technicians are aware of the issue and are working to resolve the issue as quickly as possible. We anticipate a status update on this issue in 60 minutes.
Posted 5 months ago. May 19, 2019 - 12:40 MDT
This incident affected: Banner Self-Service.