Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

support.msudenver.edu (Footprints) is down
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 12 months ago. Jun 01, 2018 - 07:54 MDT
Update
We are continuing to investigate this issue.
Posted 12 months ago. Jun 01, 2018 - 07:17 MDT
Investigating
We are currently investigating this issue.
Posted 12 months ago. Jun 01, 2018 - 07:16 MDT