Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

VPN Interruption
Incident Report for MSU Denver ITS
Resolved
Our VPN provider reported that it was a brief service interruption on their end. There has not been any additional reports about the VPN service. Issue appears to be resolved.
Posted Jun 25, 2020 - 14:54 MDT
Update
Issue appears to be resolved. We will continue to monitor VPN to verify service has been properly restored.
Posted Jun 25, 2020 - 12:44 MDT
Investigating
At this time, MSU Denver is experiencing an UNPLANNED SERVICE DEGRADATION on our VPN. External network is affected, access to internal network resources are still working. Technicians are aware of the issue and are working to resolve the issue as quickly as possible.
Posted Jun 25, 2020 - 12:28 MDT
This incident affected: Campus Network and GlobalProtect.