Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Ssb link not working
Incident Report for MSU Denver ITS
Resolved
The updated links to Self Service Banner from the university website have all been updated and this incident is Resolved.

If you continue to experience an error reaching the Employee Services Menu or the Student Hub menus (Main Menu, Register, Holds, etc.), please follow these steps:

- Clear your browse cache and cookies. Instructions to reset your browser can be found here: https://msudenver.teamdynamix.com/TDClient/2313/Portal/KB/?CategoryID=20108

- If you have saved bookmarks/favorites to these sites in your browser, those will need to be deleted and then please access these sites from the university website directly.

- Please reach out to our ITS Service Desk if you continue to have issues reaching Self Service sites: 303-352-7548

Thank you for your patience through this update!
Posted Apr 13, 2021 - 12:43 MDT
Monitoring
Due to a planned update, the URLs to sign into the self-service menus from the Student hub and Faculty and Staff hub have updated. These links include he buttons for the Main Menu, Registration, Employee Services Menu, etc.

If you are accessing these links from the Student Hub or Fac/Staff website directly and experiencing errors, please clear your browser’s cache and cookies.
Please visit our KBs on how to reset your browser here:

https://msudenver.teamdynamix.com/TDClient/2313/Portal/KB/?CategoryID=20108


If you have saved bookmarks/favorites to these links in your browser, those will need to be deleted and then please access these the Self Service links from the university website directly.
Posted Apr 13, 2021 - 11:38 MDT
Investigating
Hello. If you’re having issues with logging into student self service banner (ssb), please log in through the student hub and refresh your browser. Please call the service desk if you continue to have problems. Thank you
Posted Apr 13, 2021 - 10:54 MDT
This incident affected: ITS Scheduled Maintenance and Self Service Banner.