Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Various O365
Incident Report for MSU Denver ITS
Resolved
Microsoft has reported that the issue is now resolved and all services are once again operational.
Posted Apr 01, 2021 - 17:19 MDT
Update
Microsoft reports that after moving traffic to their resilient DNS, services are beginning to recover. Some users may still experience issues for the next half hour or so, but should start to see all O365 services begin to work again.
Posted Apr 01, 2021 - 16:56 MDT
Monitoring
From Microsoft: [We've] rerouted traffic to our resilient DNS capabilities and are seeing improvement in service availability. We are continuing to investigate the cause of the DNS issue. The next update will be provided in 60 minutes or as events warrant.
Posted Apr 01, 2021 - 16:34 MDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 01, 2021 - 16:33 MDT
Identified
Microsoft has reported they are experiencing some issues with their DNS, which is affecting use of O365 apps. This may include Teams, SharePoint, and others. This problem is affecting some, but not all users. An update will be provided in an hour unless resolved sooner.
Posted Apr 01, 2021 - 16:12 MDT
This incident affected: Office 365/Email.