Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

AurariaNet and Guest Network Service Interruption

Incident Report for MSU Denver ITS

Resolved

Wireless network services have been restored across campus. ITS will continue to monitor closely.
Posted May 02, 2025 - 09:50 MDT

Investigating

Wireless network access is down for AurariaNet and Guest network. We are investigating and will update status as more information becomes available.
Posted May 02, 2025 - 08:28 MDT
This incident affected: Campus Wireless Network.