Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Network printers unavailable across campus
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Feb 22, 2022 - 16:02 MST
Update
We are continuing to work on a fix for this issue.
Posted Feb 22, 2022 - 15:08 MST
Update
We have identified and are currently implementing a fix for the issue.
Posted Feb 22, 2022 - 14:42 MST
Update
We are continuing to work on a fix for this issue.
Posted Feb 22, 2022 - 14:22 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2022 - 14:21 MST
This incident affected: PaperCut (Student Computer Lab Printing Services).