Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

O365 Self-Service password reset
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Mar 04, 2021 - 17:54 MST
Investigating
Currently, self-service password reset is not working. We believe we have identified the issue and are working to resolve it. The status page will be updated soon.
Posted Mar 04, 2021 - 16:40 MST
This incident affected: Authentication & Single Sign On.