Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

ITS Scheduled Maintenance on March 2, 2024
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Mar 01, 2024 - 14:27 MST
Update
We are continuing to monitor for any further issues.
Posted Mar 01, 2024 - 14:22 MST
Monitoring
MSU Denver ITS will perform maintenance on Team Dynamix Ticketign System from midnight until 4:00 a.m. on Saturday March 2. Team Dynamix Ticket may not be available during this time. If you have any questions or concerns, please contact the ITS Service Desk at 303-352-7548 or visit msudenver.edu/gethelp.
Posted Mar 01, 2024 - 14:22 MST
This incident affected: ITS Scheduled Maintenance.