Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

MSUDenver.edu is unavailable. Subpages are available.

Incident Report for MSU Denver ITS

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 13:01 MDT

Investigating

We are working with the vendor to resolve this as quickly as possible.
Posted Apr 14, 2025 - 12:34 MDT
This incident affected: www.msudenver.edu - University Website.