Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner is slow login
Incident Report for MSU Denver ITS
Resolved
The incident has been resolved and the service is back to normal. The team is investigating the root cause through the problem ticket: 18388813
Posted Aug 23, 2021 - 09:37 MDT
Update
We are continuing to investigate this issue.
Posted Aug 23, 2021 - 09:28 MDT
Investigating
At this time, MSU Denver is experiencing an service degradation impacting Banner Self Service (Student/Faculty Hub Main Menus) and Banner Admin Pages (Internet Native Banner 9).

Users are experiencing either very slow performance or their logins to either system are timing out.
Posted Aug 23, 2021 - 09:27 MDT
This incident affected: Self Service Banner 8 (Faculty Self Service, Employee Self-Service, Finance Self-Service).