Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Network Service Degradation
Incident Report for MSU Denver ITS
Resolved
Issue appeared to have been caused by an automated DDoS prevention that was tripped on our website hosting provider. We have reached out to our website hosting provider and they have removed that block. Websites should be accessible again through MSU Denver's secure WiFi.
Posted Dec 08, 2021 - 15:59 MST
Investigating
We have received multiple reports of website service degradation on campus, users on the secure wifi are unable to access the MSU webpage. Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Dec 08, 2021 - 15:04 MST
This incident affected: Campus Wireless Network and Campus Web Hosting.