Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Lyris List Interruption
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 09, 2018 - 23:00 MDT
Investigating
At this time, MSU Denver is experiencing a Planned SERVICE DEGRADATION on Lyris List. Technicians are aware of the issue and are working to resolve the issue as quickly as possible. We anticipate a status update on this issue in 60 minutes.
Posted 2 months ago. Aug 09, 2018 - 21:37 MDT
This incident affected: Lyris.