Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Global Protect Issue
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 15:17 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2020 - 12:44 MDT
Investigating
We have received multiple reports of Global Protect degradation on campus. Technicians are aware of the issue and are working to resolve as quickly as possible.
Posted Mar 11, 2020 - 11:41 MDT
This incident affected: Campus Network, Wireless Network, and VPN Services.