Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

ITS Service Desk and Enrollment Services Call Center phone service Interruption
Incident Report for MSU Denver ITS
Resolved
Correction emails from Financial Aid have been sent to students and call queue volume has decreased significantly. The Enrollment Services and ITS Service Desk phone numbers have call service restored.
Posted Dec 22, 2021 - 16:33 MST
Update
We are continuing to work on a fix for this issue.
Posted Dec 22, 2021 - 16:24 MST
Identified
At this time, MSU Denver is experiencing an unplanned service interruption calls into the Enrollment Services main line departments (Financial Aid, Admissions, Registrars, General inquiry) and the IT Service Desk.

The call center system has reached capacity due to a large number of calls into Financial Aid; An email from the Office of Financial Aid was sent out in error regarding Return of Funds. Please disregard message at this time. For your financial aid status, you may check your profile from the Student Hub.

University teams aware of the issue and are working to communicate the correction as quickly as possible.
Posted Dec 22, 2021 - 15:20 MST
This incident affected: ShoreTel Call Center Services.