Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Campus phones unable to call Verizon phones
Incident Report for MSU Denver ITS
Resolved
During investigation we were unable to reproduce the issue. This appears to have been isolated or temporary.
Posted 12 days ago. Jul 10, 2019 - 15:54 MDT
Investigating
Campus phones unable to call Verizon phones (scope and impact unknown currently)
Posted 12 days ago. Jul 10, 2019 - 13:21 MDT
This incident affected: Telecommunications.