Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Emails going to Junk
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted May 27, 2021 - 16:52 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2021 - 08:43 MDT
Update
We are continuing to work on a fix for this issue.
Posted May 26, 2021 - 21:35 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 26, 2021 - 19:50 MDT
Investigating
We are currently investigating this issue.
Posted May 26, 2021 - 17:31 MDT
This incident affected: Office 365/Email.