Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Telephone Outage for External Calls
Incident Report for MSU Denver ITS
Resolved
The telephony issue is now resolved and calls are working normally.
Posted 3 months ago. Jun 03, 2019 - 09:17 MDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Jun 03, 2019 - 09:12 MDT
Investigating
We are currently experiencing a telephone outage affecting external calls. We are currently working to identify and correct this issue.
Posted 3 months ago. Jun 03, 2019 - 08:47 MDT
This incident affected: Telecommunications.