Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

DegreeWorks Service Interruption
Incident Report for MSU Denver ITS
Resolved
DegreeWorks is no longer experiencing processing delays and is back to fully operational.
Posted Apr 29, 2022 - 16:32 MDT
Update
ITS is investigating the cause of the issue with the vendor.
Posted Apr 28, 2022 - 11:01 MDT
Update
IT is still investigating the cause of the issue.
Posted Apr 27, 2022 - 13:18 MDT
Update
IT is continuing their investigation of the issue.
Posted Apr 27, 2022 - 08:33 MDT
Update
The degrade in Degree Work's performance seems to only be affected when connected to Global Protect VPN. When disconnected from the VPN there does not seem to be any loss in performance for Degree Works. IT is continuing its reasearch to determine the cause.
Posted Apr 26, 2022 - 21:41 MDT
Monitoring
At this time, MSU Denver is experiencing degraded service impacting DegreeWorks. Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Apr 26, 2022 - 17:52 MDT
This incident affected: Production - Degree Works.