Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Network Service Degradation
Incident Report for MSU Denver ITS
Resolved
We were able to work with Century Link this morning and have resolved the issue. If you are still experiencing issues accessing MSU Denver’s website, please contact the helpdesk at 303-352-7548.
Posted Dec 09, 2021 - 12:22 MST
Investigating
We are still investigating the issue with Century link users trying to access MSU Denver's website. If you are having issues, you can connect using Global Protect to access our website. More information about Global Protect can be found at https://msudenver.teamdynamix.com/TDClient/2313/Portal/KB/ArticleDet?ID=120736

Or you can use the following links to navigate to Canvas, email, and student hub menus.

Canvas: https://msudenver.instructure.com/login/saml

Email: https://email.msudenver.edu

Student Hub Menu: https://ssb.msudenver.edu/StudentSelfService
Posted Dec 08, 2021 - 15:26 MST
This incident affected: sites.msudenver.edu - Faculty/Staff personal websites.