Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

SSC Navigate Advising System Incident
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Feb 17, 2022 - 06:37 MST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2022 - 09:26 MST
Investigating
The Navigate Advising system is experiencing permissions errors for Faculty and Staff users. Many users will see a "No_User_Type" message at the top of their page. Some users will see only their Student profile, without permissions.

The MSU Denver Advising Systems team is working with the platform vendor to resolve this incident as quickly as possible.

Please check back to this status page for updates.
Posted Feb 16, 2022 - 09:14 MST
This incident affected: SSC Navigate Staff.