Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Websites unavailable
Incident Report for MSU Denver ITS
Resolved
All related systems and applications should be functioning as usual. If you still notice any issues accessing or utilizing campus systems or applications, please contact the ITS Service Desk at 303-352-7548 or visit https://www.msudenver.edu/technology/
Posted Feb 29, 2024 - 09:39 MST
Monitoring
ITS has implemented a fix to resolve the issues connecting to msudenver.edu. The issue should now be resolved, however we are continuing to monitor the systems.
Posted Feb 28, 2024 - 23:09 MST
Investigating
We're experiencing multiple reports of errors accessing www.msudenver.edu and possibly other websites. Technicians are aware of the issue and are working to resolve it as quickly as possible.
Posted Feb 28, 2024 - 21:33 MST
This incident affected: www.msudenver.edu - University Website.