Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Microspft 365 Outage

Incident Report for MSU Denver ITS

Monitoring

Microsoft states that the M365 issues have been resolved. ITS is getting reports that some external emails sent earlier are being delivered this morning. We are continuing to monitor. Please report any issues that you experience.
Posted Jan 23, 2026 - 09:21 MST

Identified

Microsoft 365, formerly Office 365, encompasses subscription plans that allow use of the Microsoft Office software suite over the life of the subscription, as well as cloud-based software-as-a-service products for business environments, such as hosted Exchange Server, Skype for Business Server, and SharePoint, among others.
Posted Jan 22, 2026 - 13:46 MST
This incident affects: Office 365/Email.