Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

[Correction] Canvas Service Interruption
Incident Report for MSU Denver ITS
Resolved
Monitoring has been completed
Posted Sep 22, 2022 - 10:16 MDT
Update
The MSU Denver Canvas environment experienced an unplanned service interruption. Instructure Canvas has resolved the issue, however, Canvas is continuing to monitor to ensure there are no further service interruptions.
Posted Sep 21, 2022 - 12:50 MDT
Monitoring
The MSU Denver Canvas environment experienced an unplanned service interruption. Instructure Canvas has resolved the issue, however, Canvas is continuing to monitor to ensure there are no further service interruptions.
Posted Sep 21, 2022 - 12:47 MDT
This incident affected: Canvas.