Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Banner 9 Admin Pages - Service Invocation Failed error
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 27, 2019 - 17:25 MDT
Investigating
The other Banner 9 Admin Page server is overloaded. In order to resolve this, we will be cycling it today. Please save your work prior to 5 PM. If you lose connectivity to Banner 9, please log on again.
Posted 3 months ago. Jun 27, 2019 - 13:52 MDT
This incident affected: Internet-Native Banner.