Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Administration Data Center Generator
Incident Report for MSU Denver ITS
Resolved
The impacted hardware has been replaced, and the backup generator is now functioning as expected. No outage was required to resolve this issue.
Posted Oct 31, 2022 - 14:05 MDT
Monitoring
AHEC has determined that the Administration Building’s backup generator is experiencing a hardware issue, resulting in the generator supplying power to the Admin Data Center rather than grid power. All services are currently operational and facilities teams are aware of the issue and working to resolve it. ITS will monitor all services hosted in the impacted data center to ensure ongoing operation.
Posted Oct 30, 2022 - 21:10 MDT
This incident affected: ITS Scheduled Maintenance.