Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Legitimate emails incorrectly quarantined/marked as malicious in Office 365
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted May 11, 2021 - 10:54 MDT
Update
Issues where users were previously unable to send or receive email from multiple legitimate domains such as Google, or DropBox have been resolved. Users who were unable to access links within emails as they were identified as risky is no longer occurring for legitimate email. All known impacted users who may have been blocked from sending emails, if their messages were incorrectly flagged as spam or phishing attempts, have been unblocked. We are continuing to monitor for any further issues.
Posted May 11, 2021 - 09:35 MDT
Update
We are continuing to monitor for any further issues.
Posted May 11, 2021 - 09:31 MDT
Update
We will be monitoring the incident till tomorrow. Emails should be operational for most part.
Posted May 10, 2021 - 16:26 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2021 - 15:13 MDT
Update
Still investigating the issue. No update.
Posted May 10, 2021 - 15:04 MDT
Update
We are still investigating the issue. No further update.
Posted May 10, 2021 - 14:14 MDT
Update
No update as of now. We are still investigating the issue.
Posted May 10, 2021 - 12:59 MDT
Investigating
We have been made aware that some users are seeing legitimate emails quarantined or marked as malicious in Office 365. We are currently investigating the issue.
Posted May 10, 2021 - 11:53 MDT
This incident affected: Office 365/Email.