Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Lyris appears not be be functional
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 17:24 MDT
Investigating
We are currently investigating this issue.
Posted Jun 01, 2020 - 13:38 MDT
This incident affected: Lyris.