Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

PeopleAdmin Intermittent Service Interruptions
Incident Report for MSU Denver ITS
Resolved
At this time no further system instability has been reported. The vendor will continue to monitor the system and we may reopen this incident if the issues re-emerge.
Posted Jan 14, 2020 - 17:55 MST
Investigating
The hosted PeopleAdmin platform has experienced recurring interruptions in availability for the last several days. The vendor's support team has been notified and they are evaluating the issue at this time.
Posted Jan 08, 2020 - 13:25 MST
This incident affected: PeopleAdmin.