Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Service Desk Phone Outage
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 17:18 MDT
Update
When calling in, callers may get disconnected after selecting a number from the prompt. We are continuing to investigate this issue.
Posted Apr 05, 2021 - 16:44 MDT
Investigating
We are currently investigating this issue. When calling in, callers may get disconnected after selecting a number from the prompt.
Posted Apr 05, 2021 - 15:46 MDT
This incident affected: ShoreTel Call Center Services.