Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Power Interruption- Administration Building
Incident Report for MSU Denver ITS
Resolved
The power issue to the data center is resolved.
Posted Sep 29, 2023 - 14:39 MDT
Update
Power is back to the data center monitoring services
Posted Sep 29, 2023 - 13:47 MDT
Identified
Power to the Administration building has been interrupted, which may result in service interruptions for select campus systems as well as network and telephony services within Admin.

Technicians are aware of the issue and are coordinating with AHEC electricians to determine the cause and restore services.
Posted Sep 29, 2023 - 13:27 MDT
This incident affected: Campus Network, File Management/Shared Network Drives, and Telecommunications.