Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Unable to Receive/Make Calls To/From External Sources
Incident Report for MSU Denver ITS
Resolved
A fix has been implemented to the Skype for Business service for external call routing has been restored.
If you still experience any issues, please contact us by calling 303-352-7548.
Posted Mar 21, 2022 - 11:47 MDT
Investigating
Currently experiencing issues with Skype for Business. Unable to receive/make calls to/from external sources. Internal calls are working as expected.
Posted Mar 21, 2022 - 09:16 MDT
This incident affected: Skype for Business.