Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Campus Phones Cannot Dial Out
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 14:57 MST
Update
We powered on the UPS where the CL circuit is connected again. Calls are now functional again.
Posted Nov 09, 2020 - 14:57 MST
Investigating
We are currently investigating this issue.
Posted Nov 09, 2020 - 14:33 MST
This incident affected: Skype for Business.