Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Error occurring with Digital Measures
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 09:33 MDT
Update
We are continuing to work on the fix for this issue.
Posted Jun 02, 2020 - 09:16 MDT
Update
We are continuing to work on this issue.
Posted Jun 01, 2020 - 13:16 MDT
Identified
The issue has been identified and we are working on the fix.
Posted Jun 01, 2020 - 10:22 MDT
Investigating
We are currently investigating the issue.
Posted Jun 01, 2020 - 10:21 MDT
This incident affected: Digital Measures.