Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Campus Phone Service Disruption
Incident Report for MSU Denver ITS
Resolved
Technicians restored the secondary connection for phone service this morning. All telecommunications services are operational and redundantly connected.
Posted 3 months ago. May 03, 2019 - 11:10 MDT
Update
All telecommunications services are functioning normally. The primary connection is restored. CenturyLink will continue working on restoring the secondary connection. MSU Denver IT Services will continue to monitor.
Posted 3 months ago. Apr 26, 2019 - 08:41 MDT
Monitoring
CenturyLink has replaced their defective equipment. Service is restored. We will continue to monitor overnight.
Posted 3 months ago. Apr 25, 2019 - 16:16 MDT
Update
All telecommunications services have been restored. The primary connection is restored. CenturyLink will continue working on restoring the secondary connection.
Posted 3 months ago. Apr 25, 2019 - 16:14 MDT
Update
All telecommunications services have been restored. The primary connection is restored. CenturyLink will continue working on restoring the secondary connection.
Posted 3 months ago. Apr 25, 2019 - 16:12 MDT
Identified
CenturyLink technicians have identified the root cause and are planning to replace faulty equipment.

The vendor estimates that service will be restored at approximately 4pm Mountain Time.
Posted 3 months ago. Apr 25, 2019 - 15:03 MDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 25, 2019 - 14:14 MDT
Update
MSU Denver IT Services is working with CenturyLink to resolve issues with calls to and from the campus. Internal calls between MSU Denver extensions are working, but our primary and redundant connections between campus and CenturyLink are down. This includes calls to AHEC, CU Denver, and Community College of Denver numbers.

We have no estimated timeframe for restoration of service, but we will update our progress at https://msudenverits.statuspage.io/

As a result of this service disruption, 911 calling from MSU Denver campus phones is not available. In order to reach Auraria Police to report an emergency, use a campus emergency phone, dial (303) 556-5000 from a mobile phone, or leverage the Text A Tip Service via (720) 593-8477.
Posted 3 months ago. Apr 25, 2019 - 14:10 MDT
Update
CenturyLink is working with us to determine why both our primary and redundant connections are down. An ETA for restoring service isn't available. Internal calls between extensions are working, but no calls can be completed from MSU Denver extensions to external numbers, including calls to AHEC, UC Denver, and CCD.
Posted 3 months ago. Apr 25, 2019 - 14:07 MDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 25, 2019 - 10:12 MDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 25, 2019 - 09:50 MDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 25, 2019 - 09:28 MDT
Investigating
ShoreTel is having incoming and outgoing call issues. Help Desk and Enrollment Services are the departments impacted. Help Desk and Enrollment Services are unable to take incoming or make outgoing calls.

Skype external calls are also receiving fast busy signal when making external calls.
Posted 3 months ago. Apr 25, 2019 - 09:11 MDT
This incident affected: Telecommunications.