Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Self Service Banner unavailable
Incident Report for MSU Denver ITS
Resolved
We have resolved issues preventing access to Self Service Banner and the system has been tested and restored to full service. All related systems and applications should be functioning as usual. If you still notice any issues accessing or utilizing campus systems or applications, please contact the ITS Service Desk at 303-352-7548 or visit msudenver.edu/gethelp. We apologize for the disruption in your daily activities during this unexpected outage.
Posted Oct 16, 2020 - 13:29 MDT
Update
We are continuing to investigate this issue.
Posted Oct 16, 2020 - 12:10 MDT
Investigating
At this time, MSU Denver is experiencing an unplanned service degradation on Self Service Banner. Technicians have been notified and are working to resolve the issue as quickly as possible. We anticipate a status update on this issue in 60 minutes.
Posted Oct 16, 2020 - 11:26 MDT
This incident affected: Self Service Banner.