Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

MFA Phone Authentication issues
Incident Report for MSU Denver ITS
Resolved
We are no longer receiving reports that MFA phone call authentications are having any issues.
Posted Jun 16, 2020 - 10:57 MDT
Investigating
We have received multiple reports of users experiencing issues with MFA when set to call a user for authentication. We believe the issue is potential with local cell carriers in the area.

If you are experience issues with receiving MFA calls we recommend changing the primary method of verifying MFA to the Microsoft Authenticator App on your individual account. Instructions for this change and additional information on MFA can be found on MSU Denver's official site at:

https://www.msudenver.edu/accounttypes/mfa/
Posted Jun 15, 2020 - 18:39 MDT
This incident affected: Authentication & Single Sign On.