Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Enrollment Services and ITS Call Center Phone Outage
Incident Report for MSU Denver ITS
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 10:48 MDT
Monitoring
At this time, MSU Denver is experiencing an unplanned service interruption impacting the Enrollment Services and IT Services call centers. Callers are not connected and hear silence with they dial the university main line (303-556-5740), Financial Aid main line, Registrars Main line, Admissions Main Line, or the ITS Service Desk (303-352-7548).

Technicians are aware of the issue and are working to resolve it as quickly as possible. We anticipate a status update on this issue in the next 60 minutes.
Posted Sep 15, 2021 - 09:45 MDT
This incident affected: ShoreTel Call Center Services.