Status

The Metropolitan State University of Denver status page provides real-time information about the status of our services.

Microsoft Office 365 is down.
Incident Report for MSU Denver ITS
Resolved
Office 365 service are back online.
Posted 6 months ago. Jan 29, 2019 - 14:49 MST
Update
Office 365 server are currently down. This includes portal, exhcange, and teams etc.
Posted 6 months ago. Jan 29, 2019 - 14:39 MST
Investigating
We are currently investigating this issue.
Posted 6 months ago. Jan 29, 2019 - 14:37 MST
This incident affected: Office 365/Email.